​ ​ ​ ​ S2Bot(Win) v.0.1.0 + BLED112 Dongle + Sphero BB8
Results 1 to 3 of 3

Thread: S2Bot(Win) v.0.1.0 + BLED112 Dongle + Sphero BB8

  1. #1
    New Member
    Join Date
    May 2018
    Location
    Russia, Saint Petersburg
    Posts
    4

    Default S2Bot(Win) v.0.1.0 + BLED112 Dongle + Sphero BB8

    Hi guys,

    Did anyone try connecting S2Bot(Win) v.0.1.0 via BLED112 with Sphero BB8 (on the latest firmware)?
    On my machine (Win10 Enterprise) S2Bot(Win) hangs with "Attempting to communicate with BB8" status.
    Disconnect-Connect never works. Droid is on woken-up state, tried pairing it with Sphero native iOS app - works like a charm.
    Also tried S2Bot App - it scans for droid forever. Also noticed that S2Bot App uses integrated bluetooth device, not BLED112 as S2Bot(Win) does.

    Would be glad to hear if somebody solved that issue.

    Thanks.

  2. #2
    New Member
    Join Date
    May 2018
    Location
    Russia, Saint Petersburg
    Posts
    4

    Default

    Also is there a way to run s2bot in debug/trace mode to see what's going on?
    Here's the only one picture I see while trying to connect to BB8:
    s2bot_bb8.png

  3. #3
    New Member
    Join Date
    May 2018
    Location
    Russia, Saint Petersburg
    Posts
    4

    Default

    Finally I was able to get it working.

    The main problem was with BLED112 used dongle that I bought a few days ago. It was running under some custom firmware and not working properly.
    I repatched dongle with default "ble-1.3.2-122\example\dkble112\usbcdc\out-ble112.hex" (higher versions including the latest available were not working for some reason).
    Right after that S2Bot was able to see a dongle and started operating normally, so I was able to connect to BB8.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •