​ ​ ​ ​ Check Syntax Greyed Out
Results 1 to 8 of 8

Thread: Check Syntax Greyed Out

  1. #1
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Question Check Syntax Greyed Out

    In PE 6.0.9.3 (Windows 7) (and previous versions), why are the check syntax buttons greyed out (inaccessible) on the Home menu and the Quick Access toolbar?

    Not always, but at times.

    Check syntax seems to always be available on the Simulate and/or PICAXE menus.
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

  2. #2
    Technical Support
    Join Date
    Jan 1970
    Location
    Bath,UK
    Posts
    6,459
    Blog Entries
    1

    Default

    This is generally when you are on a file that doesn't compile by itself (e.g. an .inc include file as opposed to the main .bas file).
    PICAXE Technical Support

  3. #3
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Default

    Yes, of course, however, there is some situation that develops that causes the check syntax on at least the home menu to be greyed out on a compile able file.

    I've seen it a lot.
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

  4. #4
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Default

    I've just started a new Workspace and a new basic file. The "Home" tab has greyed out the check syntax button on the ribbon. It is available, this time, on the simulate and PICAXE tabs. This condition exists even though I've pasted example code from the web site and saved it. The same condition applies to the quick access toolbar.

    FYI.
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

  5. #5
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Default

    So, I've become aware of this problem again this morning by loading two different Workspaces (different instances.)

    The one I'm working on includes a Code Files list of basic files, but the Workspace is loaded with more files than that on Tabs. The last file in the Workspace Tab area is an INCLUDE file (.basinc).

    My reference Workspace has a mix of basic and INCLUDE files in the Code Files list. The last file on the Tab area is a basic file (.bas).

    The first Workspace above has a greyed-out "Check Syntax" button on the Home tab, but a working one on both the Simulate and PICAXE tabs.

    The reference Workspace has a working "Check Syntax" button on all three tabs.

    ...

    Can it be that the difference between greyed-out and working is that the INCLUDE file is loaded in the last Workspace tab?


    PS. PE 6.0.9.3 (Windows 7) (and previous versions)
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

  6. #6
    Technical Support
    Join Date
    Jan 1970
    Location
    Bath,UK
    Posts
    6,459
    Blog Entries
    1

    Default

    Thnaks for the feedback. We've still not been able to reproduce this error but will continue looking. Any greyed out button should (in theory) re-enable as soon as you click onto any normal 'BASIC' tab.
    PICAXE Technical Support

  7. #7
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Default

    re-enable as soon as you click onto any normal 'BASIC' tab.
    I understand completely, but I've been working all morning on this Workspace without a change in that button.

    The heck of it is that it doesn't do this all the time, so I'm using it as an excuse to stop programming for a few minutes.

    More later ....
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

  8. #8
    Senior Member
    Join Date
    Feb 2010
    Location
    Don't Mess With My Texas!
    Posts
    2,560
    Blog Entries
    7

    Default Check Syntax

    I know this doesn't shed much light on the subject, but a quick screen shot (and crop) shows the button greyed out and unavailable. FYI.

    CheckSyntaxGreyedOut.png
    - Tex
    __________________________________________________ _______________________
    These words are my opinion, WYLION. Any resemblance to truth or fiction is accidental at best.
    "Truth lies dormant in our future history." ― Tex Clodhopper LXVI
    "Confidence is ignorance. If you're feeling cocky, it's because there's something you don't know." ― Eoin Colfer, Artemis Fowl

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •