​ ​ ​ ​ Sorties reliées en interne au "-" hors alimentation du µC ?
Results 1 to 8 of 8

Thread: Sorties reliées en interne au "-" hors alimentation du µC ?

  1. #1

    Post Sorties reliées en interne au "-" hors alimentation du µC ?

    Bonjour,

    Lorsque la patte "-" d'alimentation d'un picaxe est reliée à la masse
    et que la patte "+" n'est pas raccordée,
    les pattes en output sont-elles reliées à la masse?


    Je ne connais pas l'architecture interne d'un µC mais à ma grande surprise, le circuit test suivant semble montrer que c'est le cas!
    montage test.png

    Je m'attendais en effet à ce qu'aucun courant ne circule de l'émetteur vers la base du PNP (le potentiel de cette dernière étant fixée au + par une R 10k).
    Mais en fait non, le transistor est passant car le µC démarre et execute le code qui allume la LED en sortie B5. (B0 ne peut etre qu'une sortie).

    Cela vous étonne-t-il?
    Est-ce normal ou bien faut-il suspecter un composant défectueux (µC ou PNP)?

    D'avance merci
    Attached Images Attached Images

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    34 France
    Posts
    3,832

    Default

    Un µC démarre par l'initialisation des broches permettant la programmation ICSP. Il est donc possible que cette broche en fasse partie. Voir doc Microchip du 14M2.
    Sinon, il peut démarrer aussi par une entrée reliée à un potentiel > 1.8V par alimentation fantôme.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème . (Les Shadoks)

  3. #3

    Default

    Bjr, j'ai effectué le montage exactement comme sur le schéma que j'ai fourni donc ici pas d'alimentation fantome.
    J'ai refait l'expérience en utilisant d'autres sorties (non-ICSP cette fois): résultat identique!
    J'ai vérifié que le transistor n'est pas défectueux.

    Ma conclusion:
    soit le µC est défectueux et j'en commande un autre;
    soit c'est normal (mais ça serait sympa que quelqu'un confirme SVP) et dans ce cas je rajoute un NPN pour obtenir le resultat escompté...

  4. #4
    Senior Member
    Join Date
    Feb 2012
    Location
    Anjou
    Posts
    359

    Default

    Bonsoir,

    Sans doute une question à poser, en anglais, sur le forum de Microchip : http://www.microchip.com/forums/f516.aspx
    Certains ont sans doute une connaissance du schéma interne du microcontrôleur

  5. #5
    Senior Member
    Join Date
    Mar 2012
    Location
    Meuse(55) FRANCE
    Posts
    118

    Default

    Bonsoir,
    Ici
    Cordialement: Jean Claude.

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    34 France
    Posts
    3,832

    Default

    J'avoue ne pas trop comprendre la finalité de ce schéma ! qui commence, l’œuf ou la poule?
    Car lors du start up du µC il peut se passer n'importe quoi, sans oublier qu'ensuite le boot picaxe lui aussi va agir sur les pins. Par exemple les sorties passent en haute impédance un court instant, ce qui est à prendre en compte par exemple avec un FET.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème . (Les Shadoks)

  7. #7

    Default

    @technoman et @chimere322 : merci pour les liens, mon anglais est mauvais mais j'essaierai de voir ce que je peux faire... Sinon un petit test par qqn qui a un picaxe répondrait aussi bien à la question

    @PieM: Le schéma tel quel ne sert qu'à mettre en évidence que l'output de mon picaxe (défectueux?) est reliée en interne au "-" avant meme d'etre alimenté.*

    Comment en suis-je arrivé à faire ce montage test? ben c'est un version (très) épurée du vrai montage qui lui, est censé autoriser ou non l'alimentation par batterie de secours (en plus de l'alim principale). C'est ainsi que je me suis aperçu que l'alim de secours était "autorisée" systématiquement lorsque le picaxe n'est plus alimenté par la principale. Donc c'est facile à corriger par l'ajout d'un NPN et 2 R mais je voudrais d'abord m'assurer que le résultat observé n'est pas dû à une défaillance du µC (qui a déjà servi à d'autres tests plus hasardeux). Voilou

    *P.S. A la place de ce circuit test, on pourrait tout aussi bien raccorder le collecteur du PNP à une R + LED à la masse plutôt qu'au "+" du µC et on constaterai que la LED s'allume alors que le picaxe n'est pas alimenté ( sa borne "+" non raccordée et borne "-" à la masse).

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    34 France
    Posts
    3,832

    Default

    Dire que les pins sont reliées à V- est abusif puisque le circuit n'est pas alimenté.
    Par contre je répète qu'il y a des diodes de protection sur chaque broche (sauf sur certaines), donc un courant peut passer d'une broche vers Vss, via l'entrée Vdd du µC.
    Vu la R de 10k il suffit de 70 µA pour atteindre Vbe !
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème . (Les Shadoks)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •