PDA

View Full Version : Logicator 2005 help



Cristian C.
01-03-2009, 16:26
Trying to program a PicAxe 08M with the USB cable I've got:

Error-Hardware not found on COM4
Possible causes:
1.HW not connected.
2.HW not powered.
3.HW needs a reset.
To do this, pres and hold down 'reset' on the hw...
...then click 'run' on the screen...
...then release the reset switch

my comments: 1 and 2 are not true, as all are connected and powered
3 where is that reset switch (on the 08M?!?) and what means "click 'run' on the screen" ?
The only RUN is on the test side.

Please help.
Cristian

hippy
01-03-2009, 18:55
I'm not familiar with Logicator 2005 but what it is basically saying is that the software cannot communicate with the PICAXE chip. The "possible causes" are generic reasons a download may fail and are not all applicable to every chip, for example the 08M does not. as you note. have a Reset switch. These are also only the most common causes for download failure. There is a "download checklist" which can be found in PICAXE Manual 1 of the Programming Editor.

It may be worthwhile installing the Programming Editor to see if that can be used to communicate with the PICAXE or can help with resolving what the problem is.

The first thing to check is that the USB cable is on COM4 and is connected to the PICAXE board.

Have you successfully downloaded to any PICAXE chips using this configuration ? Which OS are you using, and which USB cable ( USB010, AXE027 or something else ) ?

Cristian C.
01-03-2009, 22:36
Thank you for your time.
My first attempt to burn works from the first try.
This is the second one, with some code modifications, on the same pic.
Have I to change the pic?.
Windows XP Home, Axe027.
The PC sounds 'OK' when it is inserted or extracted.
Device manager: COM 4. The same USB port as installed.
Fresh batteries, 4.7 volts.
Trying to reset by cutting power: the same error.

lbenson
01-03-2009, 22:40
Some programs running on a PICAXE chip can cause the download not to work, such as those which change the speed. I also am not familiar with the Logicator, but have you tried turning off power to the chip, starting the Logicator download from the PC, and then turning on power to the chip?

Cristian C.
02-03-2009, 08:23
I've done that 'power-off reset' with the same result:
1.power off
2.click 'program pic'
3.1 power on (during the 'program' window active )
3.2 [the same power on after the 'error' window appears]
4.the same error

Is there any way the picAxe get defective (on the serin pin) with the USB cable connected and without power?

When programmed, is PicAxe communicating bi-directionally with the PC?

Tricky Dicky
02-03-2009, 21:46
Christian

When you say you are using the same com port i.e. COM 4 as installed did you have the AXE027 plugged in a port as you installed the drivers and are you still using the same physical port, the AXE027 drivers are fussy about that.

As far as Logicator 2005 is concerned go to the PIC menu and select PIC type and ensure the correct COM port is selected.

Richard